mercredi 7 janvier 2015

Composer 1.0.0-alpha9 disponible

Composer, gestionnaire de dépendances PHP très connu, est passé en alpha9 le 7 décembre 2014.

Quelques modifications apportées par l'alpha9 :

  • Ajout d'une option remove, qui fait l'inverse de require, donc qui supprime une dépendance
  • Ajout d'un warning lors de l'installation d'une dépendance qui n'est plus maintenue
  • Ajout d'une option clear-cache pour vider le cache, plus besoin de le faire à la main (enfin !)
  • Amélioration des performances pour la résolution des dépendances, le gros point noir quand on commence à avoir un composer.json bien rempli

Pour mettre à jour votre composer, exécutez la commande composer self-update.

Liste des modifications de toutes les versions

Aucun commentaire:

Publier un commentaire